Credentials for download link

I was able to generate a zip archive and get zip state. Now how do I gain access to the url? when navigating to my new generated zip stream “” I get
“message”: “Credentials Error found.”,
“error”: “Access Denied”

So, this is a valid error from S3 - Access Denied.
You can get a better error by running zipstart instead(to test).
Let me know what you find out.

Does the user I setup need write permissions to my bucket? The user I setup does not. I was under the assumption that stream zip streams directly to the browser from your service at

I am now using “zip start”. I did not give it “zipTo” or any of the “destAws…” parameters. since your docs state that it would default to “{{awsBucket}}/zipped”. The AWS user does not have write permission so I would think that an error would be thrown when it attempted to place the zip file in my bucket it does not.

results from the api calls are:

zipstart returns “STARTED” & taskUUID streams3v2 zipper_s3_58ea9b9b-6660-4891-b658-7a096f969ca4

zipstate returns:
TaskUUID “zipper_web_eda768d1-e21e-4174-be18-7cb75391ceed”
taskname “idurlv2”
state “success”
results (array) value:

I am looking into it now.

I just added permissions to write to my bucket and i can now see a file called so permissions were an issue. the file name I gave it was “/” but it created the file as “/” not sure if that is normal.

so now I can create and access the file when using zip start. still though the issue I would like to resolve is zipStream.

I would have mentioned checking if you can access the zipstart URL too. Chances are that you would get the same error.
“/” is normal because you can do zip splitting in cases where you want chunks of it, or is too big to download.
I think it is read/write error. See

I can access zip start. that is what I cam currently calling to create the zip archive in my bucket. what I really need is zip stream. Isn’t “” a call to your service? why would your service respond with “{
“message”: “Credentials Error found.”,
“error”: “Access Denied”

I will check the logs to see what else is going on. I will run a few tests too

It looks like we use two different methods to check for credential validity on both API calls.
I will get streamzip updated to use the newer method that is less intrusive.

For now make sure your credentials can ListBuckets. That should solve that.
I should probably get this done by weekend end.

I added the following to the aim user but it still doesn’t work for steamship,
“Resource”:“arn:aws:s3:::my bucket”

The good news is that the new fix works. The bad news is that the code-base is mid-update and would be breaking if updated now. So expect a fix by this weekend.

Sounds good. I opened an unlimited account and will open another once this works. Thank you.

If you really need to fix that till the update, run listbuckets on your credentials with python, Php, or your programming language. Just a simple function.

It can wait till Monday. thanks

The new update is up and running.
It was tested enough but this was a big update.
Please report any bugs or errors that you find.